This project has moved. For the latest updates, please go here.

Not checking SpecFlow feature files?

Sep 4, 2013 at 11:18 AM
Wonder how to turn this on,

Best,

Dong
Coordinator
Sep 4, 2013 at 4:02 PM
Edited Sep 5, 2013 at 2:48 AM
I don't know what a SpecFlow file is. If it's got a visual designer, right click on the file, select the Open With option, and select the text editor instead.

EDIT: I had some time so I found the SpecFlow package and tried it out. The problem appears to be that the "language" is based on the text content type rather than the code content type. The text content type is not being handled (only the plaintext content type is). I've updated the provider to handle the text content type like the plaintext content type for the next release.

A workaround for the time being is to use the Open With option and select the XML Editor option. It'll treat the file as XML and will spell check it then with the quirk that you'll see a validation error at the start of the file complaining about text where the root element should be.

Eric